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Aspen 6.8 Release Notes

Enhancements to Aspen SIS
Welcome to Aspen 6.8! This release includes several improvements and new features.

Multi-factor authentication

Districts now have the option of using multi-factor authentication to add a layer of security to Aspen. The first time
users log in, they have a choice: verify using an authenticator app on their mobile device, or receive a code via email.

When logging in for the first time, users see this pop-up.

Register Multi-factor Authentication

O Authenticator & Email

Scan QR code

(7 Click here to register on this device

If you have any problems with scanning, enter the secret key
manually: Copy_key (&

Enter the code to confirm

Users can either scan the QR code using an authentication application, or click the Email tab to have a confirmation
code sent to their inbox.
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For more information, see Use multi-factor authentication in Aspen Help.

Select preferred language at login

Users can now set their preferred language on the Login pop-up.

| English v ‘

English
Portugués
Espaiiol

Q Follett As

Aspen City Schools

Login ID

Password

Trouble logging in?

(Request Account)

The selection takes place immediately, and is reflected on all Aspen Portal view pages.

For more information, see Setting Your Preferred Language in Aspen Help.

Log in with another provider

Aspen's new login pop-up supports AASP/SSO logins using another provider, such as Google or Microsoft.
If a district enables this feature, users see an option to click 'Log in with Another Provider'.

© 2024 Follett Software, LLC 5
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[USEngnsh v }

Q Follett Aspen

Aspen Public Schools

Login ID

Password

Trouble logging in?

<Request Account)

OR

(Log in with Another Pruvider)

Privacy Information

Copyright © 2003-2025
Follett Software, LLC.
All rights reserved.

Next, the user selects the provider they want to use.
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|u5 English |

Q Follett Aspen

Aspen Public Schools

Select a district
[ Aspen Integration District w ]

Select an identity provider
[Gmgle = |

(Lng in with Aﬁpﬂn)

OR

Privacy Information
Copyright © 2003-2025

Follett Software, LLC.
All rights reserved.

The user then logs in using the appropriate username and password for that provider.

For more information, see Logging on to Aspen in Aspen Help.

Password reset

Users can now reset their expired passwords, and retrieve their existing passwords, from the login pop-up. First,

click "Trouble logging in'.
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‘ English » |

Q Follett Aspen

Aspen Public Schools

Login ID

Password

Trouble logging_in

( Request Account )

Privacy Information
Copyright © 2003-2024
Follett School Solutions, LLC
All rights reserved

In the pop-up that appears, click 'Reset your password'. The following pop-up appears.
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[ English v ]

QO Follett Aspen

Aspen Public Schools

Provide your Login ID

Privacy Information
Copyright © 2003-2025

Follett Software, LLC.
All rights reserved.

Users enter their Login ID, and click Recover Password. They then follow the instructions received via email.
For more information, see Reset your password in Aspen Help.

Students and Families

Announcing Aspen's New Portal for students

If your district uses Aspen's New Portal (mobile), there is a now a New Portal view just for students. Students can
keep tabs on their assignments, schedule, grades, announcements, and more. When students log on to the New
Portal, their schedule appears. It defaults to today, but students can swipe right for tomorrow's schedule or swipe left
for yesterday's:

© 2024 Follett Software, LLC 9 . .
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My Schedule Home Page

Announcements

Friday, March 22, 2024
Good moming, Wildcats!
Wellness 2 The Fowth Quarter ends Friday, June 14, 2024| Eelore

summer bregh, talk to your teachers to find out exactly what

Grade: is expectad of you by the end of the schoal year

Teacher: There are anly 20 days left until you receive your final grades

50 lel's step it up
Room:
Quiote of the day

“with great power, there must also come - great
responsibiktyl”

Period:

Time: - Stan Lea

English 9
Grade:
Teacher:
Room:
Period:

Time:

Intro to Art
Grade:
Teacher:
Room:
Period:

Time:

For more information, see Aspen's New Portal in Aspen Help.

Class attendance appears in the New Portal

The Attendance screen now has two sub-tabs: Daily and Class. From the Daily sub-tab, parents and students can
view attendance for the Current Week, Current Grade Term, and Previous Grade Term. From the Class sub-tab,
they can view attendance for the Current Week, Current Grade Term, Previous Grade Term, and This Year.

New Notifications icon in the New Portal

Parents and students can tap the Notifications icon on the header of any screen to quickly view messages from their
district, school, and teachers.

© 2024 Follett Software, LLC 10
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My Schedule

—».;.‘

Enhancements to Returning Student Registration

If your district uses Aspen's New Student (Online) Registration/Returning Student Registration feature, you will
notice some changes when you complete a Returning Student Registration form for your student:

* On the Family/Contacts tab, you can add information (such as phone number, email address, contact notes,
and more) for the people you designate as contacts for your student. You can also edit this information for
student contacts previously entered into Aspen. If completing the form in the New Portal, you can tap Remove
to delete a contact; if done accidentally, tap Restore (the button toggles).

* After you submit a Returning Student Registration form in the New Portal, Aspen can send an email confirming
your form was received and will be reviewed.

System, District, and School Administrators

Enhancements to queries

Administrators now have more flexibility working with queries created for third-party applications to access Aspen
data.

Two new options, Modify Query and Copy Query, appear on the Options menu from the query's Details page (District
[Root Organization] view, Tools > Queries > select a query > Details > Options).

Queries :: Student + Gradebook score 4« <4« Q » »l

Jobs.
Reports
Procedures
Exports

Imports

Queries

£ =3 eD

Delete
Modify Query.
Gopy Query. Student + Gradebook score

Root Table Student

Joined Tables
Table

Gradebook Score

Join Type

Default Template

To modify a query, the administrator edits the fields on the pop-up as needed, and then clicks Save.
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Query Name Student + Gradebook score
Root Table Student v
Analytic Result -
Related Tables
Inner Join
Join Relationship Analytic Results hd
Student -
Gradebook Score
Selected Tables
Available Fields 504 End Date -
Student: Name -
Output Fields Gradebook Score: Score
-
Gradebook Score: Score AS null Mot equal to - m
Filter Fields m
:
Sort Fields
Security Roles Address Change v
System Administrator
Selected Roles

In addition, system administrators can now update a query. A new field, 'Update existing', appears on the Import
pop-up. Enable it, and click Import. Aspen will search for a query with a matching file name to update.

Bundle location Choose File | Mo file chosen

Update existing |:|

o a=

(District [Root Organization] view, Tools > Queries > Options > Import)
For more information, see Create a query for third-party applications and Export and import queries in Aspen Help.

© 2024 Follett Software, LLC 12 g9e
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New functionality for export format results

The export format Results page can now allow (with configuration) users to view errors and edit/save data to the ori-
ginal table. For example, if a student is missing a value in an Ontario School Information System (OnSIS) field, such

as Country of Origin, the user can view the error, click it, and be brought to the template where that data resides. The
user can then edit the field directly on the template.

Users click the link (shown below) to view the source data and make corrections (District [Root Organization] view,
Tools > Results > Result Rows).

Pages District Student S5taff Attendance Conduct Grades Assessment

Results :: 9/26/2023 3:56 PM :: [SASID: 0, LASID: 14] LANG ARTS, VACANCY

Reports Click to view the source detail

Procedures

Expons Description [3ASID: 0, LASID: 14] LANG ARTS. VACANCY

Imports Legal

Ouacics StaffDid s1fBB000000014
StafMlame LANG ARTS, VACANCY

Results

g Sehool0id skIBB0ODO0D303

* Result Rows
Type Teacher

Data

Interchange FTE 1.00000

Analytic Certified N

Diefinitions
YearsTeaching More

At Risk DaysAbsent 0.00

Subscriptions

Templates

Organization relationship for OAuth records updated

When a user is created at any organization level, they are always assigned an OrgOID1. If the site is multiOrg, the
user is also assigned an additional OrgOIDx for each level they are a part of. For example, in Canada, if a user is cre-
ated in a district, the user gets the OrgOID1 and OrgOID2 assigned automatically. If that user is applied to an OAuth
record as a user, then the API should look to the lowest Org level record for that user and filter on that.

If a user is created at level 4, then they would automatically be assigned OrgOID1, OrgOID2, OrgOID3, and

OrgOID4. If that user were to be applied to an OAuth record, then the API now filters on Org level 4 for the Orgs
assigned to that user.

© 2024 Follett Software, LLC 13
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Calculated field error message

The validation logic for calculated expressions is updated. Aspen now displays an error message (when the user
clicks Save) if there is an error in the 'Calculated expression' field (for example, "The user typed [ instead of {.").

]

Invalid expression, or
x procedure source is empty,

or procedure source does
not compile successfully.

(District [Root Organization] view, Admin > Data Dictionary > Calculated Fields > select a field > Details)

Ability for Intermediate organizations to edit localized reference codes

Before, when a reference code's Code or Description was localized, Aspen made the fields read-only. This could be
a problem for customers with multiple organization levels; customers at the intermediate and lower organizations
could not edit the fields created at the root organization level.

Now, the Code and Description fields are editable if the locale at the lower organization is set to the root organ-
ization's default locale. Then, users can edit existing codes and translate them the standard way in Aspen.

Data audit improvements

When an administrator runs an audit to track information updates, Aspen now displays all records from the Data
Audit and Data Audit Archive system tables. This affects the following areas:

* District [Root Organization] and School views, Global > All > select a table > Audit Records > select All
Records filter

* District [Root Organization] view, Admin > Users > select a user> Audit > select a table > select All Records
filter

* District [Root Organization] view, navigate to a list page > select a record > Details > Options > Change
History > select All Records

In addition, asterisks (****) now appear instead of passwords in these locations:

* District (Root Organization) view, Global > All > select a table > Audit Records
* District (Root Organization) view, Admin > Users > select a user > Details > Options > Change History

* District (Root Organization) view, Admin > Users > select a user > Audit

© 2024 Follett Software, LLC 14
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Query for Student Search widget updated

The search query in the Student Search widget has been updated. Student searches for semiprivate and private stu-
dents, across schools, return faster, more accurate results. (District [Root Organization] and School views, Pages)

APl enhancements

Specific enhancements were made to the Aspen APl implementation in Aspen 6.8, including the following:

* Implemented a new endpoint, /oneroster/v1p1/students/{id}/classes, which allows Aspen to send a student's
object identifier (OID) and retrieve a list of their current classes.

* Completed SendGrid API integration. Twilio SendGrid is a customer communication platform for sending email.

* Added two new options, 'OneRoster API access' and 'Query Builder API access', to the Security Roles Details
page. See Changes to System Tables, User Roles, and Privileges for information.

* 'Source field' now has a value of 'staffType' for the api.oneroster.teacher export format (District [Root
Organization] view, Tools > Exports > Export Formats > select api.oneroster.teacher > Fields > select 1 -
role). This way, users with the roles of Aide, Administrator, and Proctor are assigned their corresponding
OneRoster enumeration codes in the reply by endpoint /oneroster/v1p1/teachers. Before, users with those
roles were assigned Teacher in the reply (the 'Default value' field was set to Teacher and has been removed).

Prevent workflows from appearing in Tasks widget

A new field, 'Hide from Tasks Widget Initiation’, appears on the Workflows Details page. Select this checkbox to pre-
vent users from initiating the workflow from the Tasks widget on the homepage. (District [Root Organization] view,
Admin > Workflows > Workflow Definitions > select a workflow > Details)

For more information, see Define workflow details in Aspen Help.

Unicode data type columns for Gradebook Average system table

The Gradebook Average system table (GRADEBOOK_AVERAGE) contained OIDs that were not Unicode data
types. The data type has been changed for these Gradebook Average columns.

Class Attendance Other Code issue resolved

For schools that use second daily attendance, daily attendance has two Other Codes, one for AM and another for
PM. If Other Code 2 was used for AM class attendance and pushed to daily, daily attendance was not created. If
Other Code 1 was used for PM class attendance and pushed to daily, daily attendance was not created. This issue is
resolved by allowing teachers to use PAT_OTHER_CODE or PAT_OTHER_CODE_2 for PM attendance.

Although Aspen only provides one Other Code for AM attendance and one Other Code for PM attendance, it will not
require teachers to enter the PM attendance code in the Other Code 2 field on the class attendance record.

SYS-FUT-ADD-DROP procedure renamed

For better clarity, the procedure SYS-FUT-ADD-DROP is now called Process Future Schedule Changes. Its pre-
vious name was Process Future Enrollment Records. This procedure reviews and updates student schedule change
records. (District [Root Organization] view, Tools > Procedures). A new Schedule preference in the School view,
Procedure Run Time, indicates when Aspen should run this procedure.

For more information, see Define schedule preferences for Intermediate Organizations and schools in Aspen Help.

© 2024 Follett Software, LLC 15
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Added login security
Features were added for Aspen to shut off access to user accounts after a number of unsuccessful login attempts.

* Toflaginvalid login attempts, a new system preference sys.security.access.violation.allow was added to the
System Preference Key Definition table. It has a default value of 0 (meaning the access violation check is off).
When set to 1 or more, it defines how many times a user is allowed a login attempt before the account is
disabled.

* The User system table now has an ‘Access violation’ column (USR_ACCESS_VIOLATION_COUNT).

* The Login Status drop-down on the Users Details page has a new option: 'Disabled access violation' (District
[Root Organization] view, Admin > Users > select a user > Details). Before allowing a user to log in, Aspen
checks if the status is set to 'Disabled access violation'. If so, Aspen displays an “Account is disabled” message
to the user who attempts to log in.

'Default Login to Mobile' security preference
The 'Default Login to Mobile' checkbox was changed to a drop-down with three options:

* Blank: The preference is off.
* Classic: The preference is on and takes the user to the old mobile experience.

* New Mobile: The preference is on and takes the user to the New Portal.

This preference specifies whether users on an Aspen desktop device are directed to the New Portal or Classic
mobile.

To find this preference, go to the details of any Aspen security role (District [Root Organization] view, Admin >
Security > Roles > select a role > Details). If desired, districts can have users log on to Classic mobile first.

Note that this preference only applies to those views that have New Portal access. Other views still will default to the
Classic mobile experience.

Link added from Aspen desktop to the New Portal

A link from Aspen desktop to the Family view in the New Portal has been added (District [Root Organization] view,
Admin > Security > Roles). A new preference is Access New Mobile from Family Portal full site.

© 2024 Follett Software, LLC 16
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Logen
Session timeout 0
Attempts allowed 0

Allow access from
Restrict to
Access Mobile from Family Portal full site ]

Access New Mobile from Family Portal full site | ([

Default Portal None . v

When enabled, the Mobile View tab appears in the Family portal:

Follett Public Schools 2023-2024
Aabbott, Marybeth v @ Log Off

Aabbott, Marybeth

Pages | Mobile View

Home | Aspen Videos

Announcements

The user clicks Mobile View to access the New Portal.

'Validation Expressions' field added to validate and format values in the New Portal

A new column/field (FDX_VALIDATE_EXP_IDS) was added to the Extended Field system table (FDX). This field
defines the regular expression (regex) library Aspen uses to validate and format phone numbers that users enter on
forms in the New Portal.

—_—
Pages District  Student Staff Attendance Conduct Grades Assessment Schedule Extracurriculars Global Tools -GN _

System Tables :: Extended Field :: Validation expressions « <« Q

Users.
.

Licenses
Security
- Sequence number 260 Object identifier faxValidateExp
ata
Dictionary e Validation expressions Java bean name validatorExpressionlds
Tables: Short name ValidationExpressions Pl FDX VALIDATE_EXP_DS
Detats
+ ol 5 Databasefickdtype X
Taos Database field length | 10
Relationships
Validations Database field decimals | 0
Alias name(s)
Extensions
Reference )
Comments User data type Regex Library” v
User field length 0
Caleulated
Fields User decimal 0

Forms Validation expressions QaQ

Enhancements to Aspen's New Portal for mobile devices
Aspen 6.8 includes major developments to its New Portal (mobile). These include the following:

© 2024 Follett Software, LLC 17 g9e
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* A student portal displays students' schedules (for today, tomorrow, yesterday), as well as their assignments,
attendance (daily/class), class information, published reports (such as report cards), notifications, and more.

* Class attendance data now appears, in addition to daily attendance data.

1
A Notifications icon in the header of every screen alerts parents and students of messages from their
district, school, and teachers.

* Images added to the Announcements widget in Aspen desktop appear on mobile devices in the New Portal via
the notifications feature (revitalized for 6.8 and pending mobile app):

Message title

Message to send

0/1000

[J contacts (873 users)
Send to

[J students (1439 users)

* Forms now have Owner Table and Storage Table flexibility. This allows a greater variety of workflows, created
in Aspen desktop, to be used in the New Portal. (Workflows move forms through a process; such as from
submission to completion.) In prior releases, forms could only be associated with the Student Case storage
table. Now other storage tables, such Generic Form Data, can be selected. (District [Root Organization] view,
Admin > Forms > select a form > Details > Owner Table > Name and Storage Table > Name fields)

* Users can add basic HTML styles, such as bold, italics, and underline, to text and message resources that are
on a template.

* Onthe login screen, users now click a link to review the privacy policy. Before, a text box appeared.

Updates to Returning Student Registration

Districts that use Aspen's Returning Student Registration feature will notice the following enhancements:

* Additional functionality helps staff during the Review phase. When adding a parent, guardian, or other contact,
the pop-up displays two sub-tabs: Demographics and Contact Match. On the Contact Match sub-tab, Aspen
pre-populates the fields when a contact match is found. The reviewer can confirm the contact already exists in
Aspen, preventing duplicate contact records.

* When areviewer clicks Accept on a Returning Student Registration form, the Checklist page now displays the
following information for each student contact (under the Contacts header):

© 2024 Follett Software, LLC 18
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First Name

Last Name

° Contact Order/Priority #
Relationship

Portal Access

° Phone 1

° Phone 2

Email

Contact Notes

* Ifthe reviewer entered a new contact on the Family/Contacts tab during the Review phase, Aspen creates a
student contact record on the Student Case Person table, which can be viewed from Student > Contacts once
the registration is accepted.

* When a reviewer adds or edits Address line 3 (city, state, zip) for a student or contact, the information is parsed
into City, State, and Postal Code fields. (District [Root Organization] view, District [Root Organization] >
Contacts)

* Anew preference, Copy documents to student on Acceptance, is for districts (root organizations) that let
parents upload documents during the returning student registration process (District [Root Organization] view,
District [Root Organization] > Returning Student Registrations > Preferences > Copy Documents to
Student Y > Details). If enabled, uploaded documents appear in the District (Root Organization) or School
views, Student > Documents. If disabled, uploaded documents will still be attached to the student's Returning
Student Registration record and workflow, but will not be accessible from Student > Documents.

For more information, see Define Returning Student Registration preferences in Aspen Help.
* When a parent/guardian completes a Returning Student Registration form in Aspen desktop or the New Portal,
they can navigate to the Family/Contacts tab and add a student contact and applicable information (such as

their address, email address, phone number, contact notes, and more). In addition, the parent/guardian can
edit this information for their student's existing contacts.

* When a parent/guardian submits a Returning Student Registration form in the New Portal, Aspen can send an
email confirming the form was received and will be reviewed. Resource keys were added and can be localized:

¢ olrrForm.email.submitConfirmation.parent.subject

¢ olrrForm.email.submitConfirmation.parent.message

* When a user adds a new contact to a Returning Student Registration form (in desktop), Aspen now
automatically populates the Student Case Person table (SCP_PSN_OID) once the registrar accepts the form.
Before, Aspen only populated the table when the contact was matched manually on the Contact Match sub-tab.

(New Student [Online] Registration/Returning Student Registration is an add-on feature. Contact your Sales rep-
resentative for information.)

© 2024 Follett Software, LLC 19
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Enhancements for districts that use New Student (Online) Registration and Returning Student
Registration in Aspen's New Portal (mobile)

* Anew filter, Aspen Go, appears on the Filter menu in the District (Root Organization) view, Tools >
Templates. Select it to display forms associated with New Student (Online) Registration and Returning Student
Registration in the New Portal.

* The Student Case ID Number Generation Next value preference automatically increases each time a parent
initiates a new student registration in the New Portal. (The 'Auto assign' field must be enabled for
incrementation to occur.) (District [Root Organization] view, District [Root Organization] > Setup >
Preferences > select Membership category > click Advanced sub-tab).

* Administrators can view parents' electronic signatures on new student registrations submitted in the New
Portal.

* When a user adds a new contact to a New Student (Online) Registration form (in the New Portal or desktop),
Aspen now automatically populates the Student Case Person table (SCP_PSN_OID) once the registrar
accepts the form. Before, Aspen only populated the table when the contact was matched manually on the
Contact Match sub-tab.

* Code was updated to support the pre-population of the following fields for Returning Student Registration forms
in the New Portal. In order for the code to map to the correct user-defined field, you must add an alias to the
Data Dictionary for that user-defined field, as indicated below:

Extended DataDictionary Alias Data Dictionary Alias Data Dictionary Table
olrr-scp-access all-ctj-PickupAccess Student Contact
olrr-scp-receive-text-comm all-ctj-ReceivesTextComm Student Contact
olrr-stc-legal-note all-std-legalNote Student
olrr-stc-parent-court-order all-std-parentCourtOrder Student
olrr-stc-order-of-protection all-std-orderOfProtection Student

Updates to Continuing Education feature

Aspen's Continuing Education feature lets community members sign up for educational classes and activities offered
by their district using the New Portal (mobile). Recent enhancements to this feature include the following:

* The Continuing Education Waitlist Update procedure, SYS-CON-ED-WAITLIST-UPDATE, has been
enhanced. This procedure enrolls wait-listed students to course sections, on a first comef/first served basis, and
updates the rank of the students who remain on the list. The procedure now sends an email to newly enrolled
students. Districts can customize the email's text, as well as the priority for accepting wait-listed students.

* If a course section ends today (or earlier), the Continuing Education Waitlist Update procedure now removes
the wait list from a student's Course Registration and Course Enroliment pages.

© 2024 Follett Software, LLC 20 . .
v6.8



(
-

Follett

SOFTWARE

* The Withdraw button now appears on a course section's Details screen. Before, users could only withdraw from
the Course Enrollments screen.

* A Delete button appears on all tabs of an unsubmitted registration form. A confirmation pop-up allows the user
to cancel the action in case the button was tapped unintentionally and they do not want to delete the
registration.

* Error messages are more descriptive and aptly placed. Before, the error message appeared on the Submit tab,
regardless of which tab contained the error.

* A confirmation message appears when a user withdraws from one or more course sections.

* Users can view Announcements from the Continuing Education view in the New Portal. The administrator must
enable the 'Continuing education’ field on the Visibility sub-tab for the announcement. (District [Root
Organization] view, Pages > click Edit in the Announcements widget > click Edit or New > click Visibility sub-
tab > enable Continuing education field)

(Continuing Education is an add-on feature. Contact your Sales representative for information.)

Teachers

Set a default assignment category

Teachers can set a default assignment category for each class section. Select a class section and a category, and
then enable the new field, 'Default category for assignments'. Aspen will automatically assign that category to each
new assignment for the class. The teacher can manually edit an assignment's category, as needed. (Staff view,
Gradebook > select a class section > Categories)

For more information, see Create assignment grades on the Categories side-tab in Aspen Help.

Additional colors for special codes

Now, when selecting a color to represent a special code, teachers have a more vibrant assortment of colors to

choose from. Click the — icon at the Color field, and then click a color on the Color Chooser pop-up. Select a
color; you can make it lighter or darker by clicking a shade on the color gradations strip. The code appears in the
selected color when it is entered on the Scores page. (Staff view, Tools > Special Codes)

For more information, see Create special codes for assignment grades in Aspen Help.

Special code enhancement for missing assignments

To prevent students from receiving zero points for missing assignments, teachers can now create a special code that
is worth a percentage of an assignment's total points. For example, if a teacher creates a special code that is worth
half an assignment's total points and enters it on their Scores page, the student would receive a 50 instead of zero.
This could drastically reduce the impact on a student's average, especially for those who only miss one assignment.
(Staff view, Tools > Special Codes)

For more information, see Create special codes for assignment grades in Aspen Help.

Expanded Teacher Classes widget

The Classes Meeting and Classes Not Meeting columns are wider, so teachers can more easily recognize and inter-
act with their class sections in the widget. As before, Aspen truncates class names that are too long to display, and
hovering the cursor over the truncated name reveals the full text. (Staff view, Pages)
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Changes to Preferences

New or updated pref-

erence

Where to access

Description

Changed District (Root

Organization) and School

Class Attendance pref-
erence:

Allow date change in staff

District (Root Organization) view, District (Root Organ-
ization) > Setup > Preferences > select Class Attend-
ance category

School view, School > Setup > Preferences > select

Renamed from Allow
date change.

When this field is
enabled, staff mem-
bers can enter class

view Class Attendance category attendance for dates
other than today (Staff
view, Attendance >
Class).

New District (Root District (Root Organization) view, District (Root Organ- When this field is

Organization) and School

Class Attendance pref-
erence:

Allow date change for

class roster in school view

ization) > Setup > Preferences > select Class Attend-
ance category

School view, School > Setup > Preferences > select
Class Attendance category

enabled, staff mem-
bers can enter class
attendance for dates
other than today
(School view, Attend-
ance > Class
Roster).

New Intermediate Organ-
ization and School Schedule

preference:
Procedure Run Time

Intermediate Organization view, Intermediate Organ-
ization > Setup > Preferences > select Schedule cat-

egory

School view, School > Setup > Preferences > select
Schedule category

This field works in con-
junction with the
Allow future
add/drop preference.
The time entered here
indicates when Aspen
runs the job for the
SYS-FUT-ADD-
DROP procedure,
which reviews and
updates records
related to student
schedule changes. It
defaults to 2:00

AM but can be

changed.

Note: The pro-
cedure SYS-
FUT-ADD-
DROP is now
called Process
Future Schedule
Changes. Its pre-
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v6.8

22



) Follett

SOFTWARE

New or updated pref-
erence

Where to access

Description

vious name was
Process Future
Enroliment
Changes.

Changed District (Root
Organization) and School
Family/Student Portal pref-
erence:

Term performance display
mode

District (Root Organization) view, District (Root Organ-
ization) > Setup > Preferences > select Family/Student
Portal category

School view, School > Setup > Preferences > select
Family/Student Portal category

This preference
determines the value
that displays on the
Classes page in the
portals and on the
Classes screen in the
New Portal (mobile).
Options are Term
average (default) and

Cumulative average.

For more information,
see Define District
Family and Student
portal preferences in
Aspen Help.
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Changes to System Tables, User Roles, and Privileges

The following table lists new and updated system tables and user role security privileges in Aspen. Review your user
roles to ensure the settings are appropriate for the default user roles used in your district (root organization) and any
customized roles you've created from Aspen's default roles.

New or updated

Default roles affected Description Where to access

© 2024 Follett Software, LLC
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privilege

New fields on the
Graduation Stu-
dent Program sys-

The Graduation Stu-

dent Program table
has 5 new A fields

District (Root Organization) view,
Admin > Data Dictionary > select
Graduation Student Program

tem table (15 total) and 5 new table > Fields

B fields (10 total).
New fields on the The IEP Data table District (Root Organization) view,
IEP Data system has 20 new D fields Admin > Data Dictionary > select

table (105 total). IEP Data table > Fields
New fields on the The IEP Goal table District (Root Organization) view,
IEP Goal system has 20 new D fields Admin > Data Dictionary > select
table (23 total). IEP Goal table > Fields
New fields on the The Staff table has District (Root Organization) view,
Staff system table 10 new D fields (15 Admin > Data

total). Dictionary > select Staff table >

Fields

New fields on the The Student Attend- District (Root Organization) view,
Student Attend- ancetablehas3  Admin > Data
ance system table new A fields (4

total), 4 new B
fields (5 total), 4

Dictionary > select Student
Attendance table > Fields

new C fields (4

total), and 5new D

fields (5 total).
New fields on the The Student Event District (Root Organization) view,
Student Event Tracking table has  Admin > Data
Tracking system 25 new A fields (35

table

total), 15 new B
fields (25 total), 15
new C fields (25
total), and 5new D
fields (10 total).

Dictionary > select Student Event
Tracking table > Fields

New system table:
Tool Status

Tracks job requests
and their status.

District (Root Organization) view,
Admin > Data

Dictionary > select Tool Status
table
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New or updated
privilege

Default roles affected

Description

Where to access

New security priv-
ilege:

OneRoster API
access

System Administrator

Required for API
access by
OneRoster or cus-
tom queries.

District (Root Organization) view,
Admin > Security

> Roles > select System Admin-
istrator > select Organization at
Category. See Other column.

New security priv-

System Administrator

Required for API

District (Root Organization) view,

© 2024 Follett Software, LLC
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ilege: access by Admin > Security
Query Builder OneRosterorcus- > Roles > select System Admin-
APl access tom queries. istrator > select Organization at
Category. See Other column.
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